


The Flash workspace 
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The Flash workspace 

Stage 
The Stage is the white, rectangular area of the Adobe Flash CS3 workspace (Figure 1). Objects you place on the 
Stage will appear in your published movie. Objects placed in the pasteboard (the gray area around the Stage) will 
not appear in the finished movie, but you can place objects there until you want them to appear on the Stage. 

 Timeline Stage Tools panel Panels Property inspector 

 
Figure 1 Flash workspace 
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Timeline and layers 
The Timeline is where you control the images and sounds in your Flash document (Figure 2). The Timeline is 
divided into frames. You can add content to the frames on the Timeline. 

Current frame, frame rate, and elapsed time are all shown at the bottom of the Timeline. The playhead, represented 
by a red rectangle with a long red line, shows the current frame you are viewing on the Timeline. You can click a 
frame to move the playhead to that frame, or you can drag the playhead back and forth on the Timeline to quickly 
view all or any part of your animation. 

Layers in the Timeline provide a way to organize the elements of your movie. You can draw and edit objects on one 
layer without affecting objects on another layer. Layers control the stacking order of objects—the order moves from 
top to bottom, so objects displayed in front are in the top layer, while objects displayed in back are in the bottom 
layer. This allows you to place objects in front of or behind one another. To change the order of layers, drag the 
layer name to a new position. The layer controls appear on the left side of the Timeline. Each layer has an option for 
hiding or showing the layer, locking it, and displaying its contents as outlines. 
 

 Playhead 
Show/Hide  
Layer 

Lock/Unlock 
Layer Layers 

 
 Delete Layer Frame Current  

frame Rate 
Insert  
Layer 

Insert Layer 
Folder 

Elapsed 
Time 

Figure 2 Timeline 

Edit bar 
The edit bar, at the top of the Timeline, lets you quickly navigate between different parts of your Flash document 
(Figure 3). It indicates the current object being edited and lets you switch between scenes and symbols. You can 
also change the magnification level of the Stage. You can also show or hide the Timeline. 
 
 

Move Up  
A Level 

Change  
Magnification Edit Scene 

 
 

 

Show/Hide 
Timeline  

Current  
Object 

Edit Symbols Select Workspace 
Layout 

Figure 3 Edit bar 
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Panels 

Panels provide easy access to controls that help you work 
with the content in your document (Figure 4). By default, 
the panels are docked to the right side of the workspace. You 
can undock panel groups, add panels to a group, undock 
individual panels, rearrange the order of docked panels, and 
collapse and close panel groups. To undock a panel, drag it 
by its tab or title bar away from its current position. You can 
drag it into another dock or make it free-floating. 

 
Figure 4 Panels 

Title bar 

Tab 
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Tools panel 
The tools in the Tools panel let you draw, paint, select, and modify artwork, as well as change the view of the Stage 
(Figure 5). The Options area at the bottom of the Tools panel lets you modify a tool you have selected. If the Tools 
panel is not visible, you can display it by selecting Window > Tools. To select a tool, just click it. (You can also use 
the shortcut key shown in parentheses in the tool tip that appears when you rest the pointer over a tool for a few 
seconds.) 

Selection 

Free Transform 

 
Figure 5 Flash Tools panel 

Selection tools 

Selection tool (black arrow): Click an object to select it. Drag a selected object to move it. 

Subselection tool (white arrow): Select and move points of an object or edit paths between adjacent points. 

Free Transform tool: Resize or rotate selected objects by clicking and dragging. Also has the Gradient Transform 
tool (transform a gradient or bitmap fill by adjusting the size, direction, or center of the fill). 

Lasso tool: Click and drag to select an area. 

Drawing tools 

Pen tool: Create straight or curved lines. You can also create Bezier curves. 

Text tool: Create or edit text and text fields. 

Line tool: Draw straight lines. 

Line 

Pen 

Pencil 

Ink Bottle 

Eyedropper 

Hand 

Subselection 

Lasso 

Text 

Rectangle 

Brush 

Paint Bucket 

Eraser 

Zoom 

Stroke color 

Fill color 

Options Area 
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Rectangle tool: Create rectangles or squares composed of fills and strokes, just fills, or just strokes. Also has the 
PolyStar tool (create either polygon or star shapes—you can set how many points both shapes have), the Oval tool 
(create circles and ovals), the Rectangle Primitive tool, and the Oval Primitive tool. Primitive shapes are individual 
objects that can be edited in the Property inspector. 

Pencil tool: Create lines in any of three modes—straighten, smooth, or ink. 

Brush tool: Create shapes with fills only. 

Ink Bottle tool: Change the color or width of a line, or add a stroke to a shape. 

Paint Bucket tool: Add fill inside a shape or change the fill color. 

Eyedropper tool: Sample a color from swatches or anywhere on the screen. 

Eraser tool: Erase parts of an image. 

View tools 

Hand tool: Drag the Stage to view another part of your document. 

Zoom tool: Zoom in or out to view more or less of the Stage. To zoom out, hold down the Alt key (Windows) or the 
Option key (Mac OS). 

Color tools 

Stroke Color: Set the stroke color. 

Fill Color: Set the fill color. 

Property inspector 
The Property inspector displays options that change according to the current object or tool selection. When you 
open a document, the Property inspector displays document properties. When you select certain tools, it displays 
tool options. When you select a vector object, it displays options such as stroke and fill. You can change these and 
other options directly from the Property inspector. By default, the Property inspector is visible; you can hide or show 
it by selecting Window > Properties > Properties. Figure 6 shows the properties for a text object and a rectangle 
shape, respectively. 

 

 
Figure 6 Property inspectors 

Page 182





















How to produce Flash video for use on the web 
Adobe Flash CS3 provides a number of options for importing and publishing video with a Flash movie. 

You can import the following video formats if QuickTime 7 or higher is installed (Windows and Mac OS): 

• Audio Video Interleaved (.avi) 

• Digital Video (.dv) 

• Motion Picture Experts Group (.mpg or .mpeg) 

• QuickTime Movie (.mov) 

You can import the following file formats if DirectX 9 or later is installed (Windows only):  

• Audio Video Interleaved (.avi) 

• Motion Picture Experts Group (.mpg or .mpeg) 

• Windows Media File (.wmv, .asf) 

Deploying video 
Flash has three basic options for producing video: 

Progressive download: Flash creates a Flash video file that downloads from a regular web server and plays within 
the published SWF file. 

Embedded video: Flash converts video to Timeline frames. The video is contained entirely within the published 
SWF file. 

Stream from Adobe Flash Media Server or Flash Video Streaming Service: Although both of these options produce 
the overall best performance, they require either the Flash Media Server or a subscription to a Flash Video 
Streaming service. See the Adobe website for more information, www.adobe.com. 

Using progressive download 

1. Open an existing Flash document or create and save a 
new Flash document. 

 Note: It is important that you save the Flash document 
before you begin the video import process. 

2. Select a keyframe on the layer in which you wish to 
import the video. 

 This is where the video player will be located once the 
video import has completed. 

3. Select File > Import > Import Video. 

 The Import Video wizard opens (Figure 1). 

4. Enter a location for the video file you wish to import.  

 The video file can be located either on your computer or 
on the Internet. 

Figure 1 Import Video wizard, Select Video page
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5. Click Next. 

 The Deployment page of the Import Video wizard opens 
(Figure 2). 

6. Select Progressive Download From A Web Server. 

 Note: This is the preferred method for using video with 
Flash if use of Flash Media Server is not possible. 

7. Click Next. 

 The Encoding page of the Import Video wizard opens 
(Figure 3). 
 
Note: If you are importing a Flash video file, then this 
step has already been done and the Skinning page will 
open.  

8. Select an encoding method based on the Flash Player 
version you intend to publish content for and the data 
rate at which you want your video content to be 
encoded. 

 Each method produces a different file size. Typically 
larger files provide higher quality, but performance may 
suffer. 

 Note: Progressive download works with Flash Player 7 
or later. 

9. Click Next.  

 The Skinning page of the Import Video wizard opens 
(Figure 4). 

 The video’s skin determines the location and appearance 
of the video controls. Visitors will see this skin when 
Flash plays the video. 

10. Select a skin from the Skin pop-up menu. 

11. Select a skin color from the Color picker. 

12. Click Next. 

 The Finish Video Import page of the Import Video 
wizard opens. This page confirms the location of the 
original video file and the new Flash Video file. 

 

Figure 2 Import Video wizard, Deployment page 

 

Figure 3 Import Video wizard, Encoding page 

 

Figure 4 Import Video wizard, Skinning page 
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12. Click Finish. 

 The Flash Video encoder runs. When the encoder 
finishes running, an FLVPlayback object appears on the 
Stage (Figure 5). 

13. Select Control > Test Movie to see it play. 

 The video plays in the Flash Player window. Observe 
that you can use the controls to stop, pause, fast forward, 
rewind, and change the volume of the video. 

14. Select File > Close to close the preview window. 

15. Open the folder in which you have saved the Flash 
document. 

 Observe that this folder now contains two new files, an 
FLV file and a SWF for the video’s skin. (The skin will 
be called something like MojaveOverAll.swf.) When 
you publish your Flash document, both of these files 
need to be copied to the same location as the Flash 
document. 

Figure 5 FLVPlayback object on Stage 

Embedding video within SWF files 

When you select the embedded video option, Flash converts video to Timeline frames. When the SWF file is 
published, the video is fully contained in that file; unlike progressive download, it requires no external file, and so is 
easier to deploy. However, because embedded video often has problems with audio synchronization after 
120 frames, Adobe recommends embedded video in only three cases: 

• When you want visitors who have Flash 5 to be able to view your video 

• When you must have one single file that encapsulates the video and the Flash content 

• When your video clip is less than 5 seconds long 

These situations are not common. In all other situations, embedded video is not recommended. 
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How to import sound 
In Adobe Flash CS3, you can import sound and video to integrate them into the Timeline. You can create media-rich 
content with very precise control. 

Importing sound 
You can use sound for many purposes in Flash. Some examples include soundtracks, narration, and sound effects 
that complement objects such as rollover buttons. 

You can import the following sound file formats into Flash: 

• WAV (Windows only) 

• AIFF (Mac OS only) 

• MP3 (Windows or Mac OS) 

If you have QuickTime 4 or later installed on your system, you can import these additional sound file formats: 

• AIFF (Windows or Mac OS) 

• Sound Designer II (Mac OS only) 

• Sound Only QuickTime Movies (Windows or Mac OS) 

• Sun AU (Windows or Mac OS) 

• System 7 Sounds (Mac OS only) 

• WAV (Windows or Mac OS) 

When you import a sound file, it’s placed in the library. Then you can drag an instance (copy) of the sound onto the 
Stage. Sound files must be tied to keyframes. 

You can synchronize a sound to your movie in several ways (using the Sync pop-up menu in the Property inspector): 

• Event: An event sound plays when the playhead reaches the first keyframe containing the sound. It plays in 
its entirety, independent of the Timeline, even if the movie stops. If a different instance of the same sound 
is started, the sounds will overlap. 

• Start: The same as Event, except that if the sound is already playing, no new instance of the sound will 
begin playing. 

• Stop: Silences the specified sound. 

• Stream: Forces the movie to keep pace with the sound. If Flash can’t draw animation frames quickly 
enough, it skips frames. Unlike event sounds, stream sounds stop if the movie stops. Stream sounds can 
also produce a much smaller file size, although their quality tends to be poorer than event sounds. 
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Import a sound 

1. Start Flash and open a document. 

2. Insert a new layer. 

3. Double-click the new layer name, and rename it Sound. 

4. Select File > Import > Import To Library. 

 The Import dialog box opens (Figure 1). 

5. Locate a sound file, select it, and click Open. 

 Note: You can download free music loops and sound 
effect clips at www.flashkit.com, for example. 

6. Select frame 1 on the Sound layer. 

7. Make sure the Library panel is open. (If not, select 
Window > Library.) 

 The sound appears in the Library panel. To preview the 
sound, click the Play button in the preview (upper) pane 
of the Library panel (Figure 2). 

 Note: You must select the sound to see the waveform of 
the sound in the preview pane. 

8. Drag the sound file from the Library panel onto the 
Stage. 

 Note: The Sound layer must contain enough frames to 
play the entire sound. For example, if your movie is set 
for 12 frames per second and your sound is 2 seconds 
long, the Sound layer must contain at least 24 frames. If 
you are adding sound to an existing movie, your movie 
might already be long enough to accommodate the 
sound. 

9. If necessary, add frames to the Sound layer. To do this, 
click a frame down the Timeline for the Sound layer, 
such as frame 24 for a 2-second movie at 12 fps, and 
select Insert > Frame. 

 The sound does not appear on the Stage but does appear 
on the Timeline as a waveform (Figure 3).  

 Note: Press the F5 key to insert a frame. Press Shift-F5 
to delete a frame. 

Figure 1 Import dialog box 

 

 
Figure 2 Library panel 

 

Figure 3 Sound in Timeline 

Play button 

Editing sound settings 

Through the Property inspector, you can change settings for the sound, including making the sound fade in and fade 
out. 

10. Select the first keyframe and adjust the settings for the 
sound in the Property inspector (Figure 4). 

Figure 4 Sound Property inspector 
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 Effect: Choose from previously created effects such as 
Fade In, Fade Out, keeping sound in only one channel 
(left or right), or fading sound from one channel to the 
other (Figure 5). Choosing Custom will open a sound-
editing window where you can create your own fading 
effects (Figure 6). In the sound-editing window, called 
the Edit Envelope, adjust the sound handles to control 
sound volume in each channel. 

 Sync: Choose Event, Start, Stop, or Stream. 

 Loop: Set the number of times to have the sound replay.

Figure 5 Effect pop-up menu 
 

 
Figure 6 Edit Envelope dialog box 

Sound compression 
Sound files can drastically increase the file size of your movies. One way to control this is to set the compression for 
the sounds in Flash. 

1. Make sure the Library panel is open, and select the 
sound file. 

2. Click the Properties button in the Library panel 
(Figure 7). 

 The Sound Properties dialog box opens (Figure 8). 

3. Choose a compression method from the Compression 
menu and click OK. 

 ADPCM: This method sets the compression for 8-bit 
and 16-bit sound data. Use this when you export short 
event sounds such as button clicks. 

 MP3: This method offers good compression and sound 
fidelity for longer stream sounds such as music tracks. 

 Raw: This resamples the file but does not perform any 
compression. 

 Speech: A good compression to use for speech sound 
files. 

4. Save the movie. 

5. Select Control > Test Movie. 

 
 

Figure 7 Library Properties button 
 

 
Figure 8 Sound Properties dialog box 

Properties button 
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How to use filmmaking techniques 
Web designers have an entire history of filmmaking techniques to draw from and inspire them when creating 
websites and digital movies. With Adobe Flash CS3, you can simulate traditional film techniques. As you design 
Flash movies, think of creative ways to incorporate these effects and look for opportunities to create new effects that 
may in turn inspire traditional filmmaking. 

Four popular filmmaking techniques include: 

• Pan, Tilt, and Zoom Effects: Moving the camera horizontally across a scene is known as a pan. Moving the 
camera up or down across a scene is known as a tilt. Moving the camera away from or toward a subject in a 
scene is known as a zoom. 

• Camera Angles: Using the rule of thirds and adjusting the viewing angle can help emphasize a certain aspect of 
the subject. 

• Cross Fades: This technique appears to fade in one image while another fades out, a transitional effect for 
moving from one image to another. 

• Bounce Effect: A moving object rebounds before stopping. This technique grabs attention and can focus the 
viewer on an area of the screen. This effect is sometimes combined with a sudden sound effect, such as a 
“boing” or tire screech. 

Create a pan, tilt, or zoom effect 
To set a scene in a movie, the camera moves over a large scene and then zooms in to a specific point. A pan (or tilt) 
followed by a zoom is a good technique to introduce a digital narrative. Zooming in focuses the viewer’s attention 
on a particular part of the image. 

1. If your image is not already a symbol, convert it to a 
movie clip symbol (Figure 1). Place the symbol on the 
right side of the workspace, covering the Stage.  

 Be sure the Stage is smaller than the image. 

2. Insert a keyframe in the Timeline where you want the 
pan to end (Figure 2). 

3. Select the ending keyframe. Drag the instance of the 
movie symbol to the opposite side of the workspace. 

 
Figure 1 Image converted to symbol 

 

 
Figure 2 Insert keyframe 
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4. Click in the Outline column to the right of the layer 
name for the layer that contains the movie symbol 
(Figure 3). 

 Note: It is easier to see the border of an image if you set 
the layer holding the image to outline mode (especially 
if the image contains a lot of grays that can fade into the 
area outside the Stage). Be sure the image does not slide 
off the Stage during a pan. 

5. Select the starting frame and select Insert > Timeline > 
Create Motion Tween. 

 This motion tween moves the movie symbol 
horizontally across the Stage (a pan). The ending 
keyframe for this motion tween will be the starting point 
for another motion tween that zooms the image 300%. 

6. Add a keyframe for the ending point of the second 
motion tween (the zoom) (Figure 4). 

7. Select the ending keyframe and select Modify > 
Transform > Scale to open the Transform panel. 
 
Transformation handles appear on the image (Figure 5).

8. Shift-drag one of the corner transformation handles to 
resize the image approximately three times its original 
size. 

 The image expands (Figure 6). 

9. Create a motion tween between the second and third 
keyframes. 

10. In the Property inspector, increase the easing to a value 
between 60 and 100 for the motion tween (Figure 7). 

 This will cause the zoom to start quickly and slow down 
as it arrives at the resting point. 

11. Add a new layer called actions as the top layer of the 
Timeline. 

12. Select the last frame of the actions layer and insert a new
keyframe. 

13. Select Window > Actions to open the Actions panel. 

14. If you don’t see the parameters area in the Actions 
panel, click the Script Assist button. 

 

 
 

Figure 3 Image outlined 

 

Figure 4 Keyframe for zoom 

 

 
 

Figure 5 Outline image with transformation 
handles 

 

 
Figure 6 Image zoomed 

 

Figure 7 Property inspector 

 Outline column 

Transformation handle 
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15. In the Actions toolbox on the left side of the panel, 
double-click the Stop method for the Flash.Display class 
(Figure 8).  
 
The code for the Stop method appears in the Script pane.
 
To find the Stop method, open Flash.Display, and then 
open MovieClip 

16. In the Script pane, select the Stop method. Then click in 
the Object field in the parameters area of the Actions 
Panel. 

 The Insert Target Path button is now active. 

17. Click the Insert Target Path button to open the Insert 
Target Path dialog box (Figure 9). 

18. Select the Relative option and select the movie clip that 
you want to play when the button is clicked. If you want 
the movie in the main timeline to play, select root to set 
the target path to this.  

19. Click OK to close the Insert Target Path dialog box. 
 
The Script pane shows the correct code for stopping the 
movie (Figure 10). 

20. Close the Actions panel. 

 
Figure 8 Stop method in the Actions panel 

 

 
Figure 9 Insert Target Path dialog box 

 

 
Figure 10 Stop method in the Script pane 
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Adding frame labels 

You may want to add frame labels to the keyframes. Frame labels help you and other designers remember what is 
happening in a particular frame. 

21. Add a new layer called labels as the top layer of the 
Timeline. Insert keyframes in this layer to correspond 
with each of the keyframes that drive the animation. 

22. Select a keyframe in the labels layer. Then open the 
Property inspector and type the name in the Frame text 
box (Figure 11). 

 The label appears along the Timeline in the frames after 
the keyframe (Figure 12). 

23. If there are no frames after the keyframe, insert a blank 
keyframe in the same layer several frames after the label 
to see the label. 

24. Turn off outlining, save the file, and select Control > 
Test Movie. 

 
Figure 11 Frame text box in Property inspector 

 

Figure 12 Frame label in Timeline 

Further ideas 

• For a documentary: Slow the process down to reflect the pace of the narrative. For example, a slow pan and 
zoom go well with a documentary style narrative. 

• For humor or action: Make the zoom-in portion of the pan quick and somewhat unsteady, as if looking for the 
subject of the scene. You might zoom in and out several times during a pan, to show you are looking for 
something in the scene. 

• For drama: Pan or tilt the scene without a zoom. This method presents a sweeping landscape, such as a 
mountain range leading to the ocean. Because it takes in the majority of the landscape, it adds depth and 
seriousness to the tone of the narrative. 
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Camera angles 
When you have several images on the screen in a digital narrative, you can use some tricks for emphasis. Use the 
rule of thirds and adjust the viewing angle to emphasize a certain aspect of the subject. 

• The rule of thirds states that if you divide the screen into a 3-by-3 grid, the intersections of the lines are areas 
where the eye will focus. Line up the items of focus at these intersections on the screen. 

• You can add importance to a subject by presenting the subject as seen from below. Likewise, you can diminish 
the importance of a subject as seen from above. 

Even though the girl isn’t in the center of Figure 13, the eye 
is drawn to her because she is near the intersection of the 
rule-of-thirds lines. 

Looking up at the man having a moment in Figure 14 makes 
him look powerful. If the camera angled down on him, he 
would look smaller and less powerful. 

 
Figure 13 Rule of thirds 

 
Figure 14 Camera angle 
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Cross fades 
A transitional effect for moving from one image to another is to fade one image out as you fade the other in. 

1. Convert into symbols two images that will be cross-
faded, and place them on separate layers. 

2. Insert keyframes in both layers at the same point in the 
Timeline to mark the beginning of the fade-out of the 
first image and the fade-in of the second image. 

3. Decide the length of the transition and insert keyframes 
in both layers at the same point in the Timeline to mark 
the end of the fade-out of the first image and the fade-in 
of the second image. 

4. Select the first keyframe for the image that will fade out, 
select the image, and use the Property inspector to set its 
alpha level to 100% (Figure 15). 

 Note: If your images are in the same position on the 
Stage, you need to hide the top layer before you can 
select the symbol in the bottom layer. It is easier to 
select your images if they are offset on the Stage. 

5. Select the first keyframe for the image that will fade in 
and set its alpha level to 0%. 

6. Select the last keyframe for the image that will fade in 
and set its alpha level to 100%. 

7. Select the last keyframe for the image that will fade out 
and set its alpha level to 0%. 

8. Select the first keyframe for each image and insert a 
motion tween. 

 Note: You can insert a motion tween by right-clicking 
(Windows) or Control-clicking (Mac OS) and choosing 
Create Motion Tween in the context menu, by choosing 
Insert > Timeline > Create Motion Tween, or by using 
the Tween pop-up menu in the Property inspector. 

9. Add Frame labels to the first keyframes of each motion 
tween (Figure 16). 

 The labels appear on the Timeline (Figure 17). 

 Note: You can make the fade-out start after the fade-in 
or vice versa. You can also extend the fade-out to end in 
the same frame as the end of the fade-in. 

 If the images zoom in or out before the fade-out, you 
probably want to continue the zooming process during 
the fade. 

10. Save the movie. 

11. Select Control > Test Movie to test the movie. 

12. Select File > Close to close the preview window. 

Figure 15 Color pop-up menu 

 

 
Figure 16 Frame label box 

 

Figure 17 Frame labels in Property inspector 
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Bounce effect 
Some animated text and images that move onto the Stage will seem more lifelike if you add a little bounce to them 
when they reach their stopping point. This is an old animation technique acknowledging that any moving object 
carries momentum and thus rebounds a bit before it comes to a stop. This technique also grabs attention and can 
focus the viewer on an area of the screen. 

1. Motion-tween a symbol so it moves across the Stage. 

 Note: When dragging the symbol to its ending point, 
hold down the Shift key to constrain the symbol so it 
moves only in the direction you drag, without shifting 
up or down. 

2. Label the starting keyframe for the motion tween Moves 
Right or Moves Left (Figure 18) and label the second 
keyframe Bounce. 

3. Insert a keyframe 3–5 frames after the end of the motion 
tween. Label this frame Back. 

4. Insert another keyframe 8–10 frames after the end of the 
original motion tween. This will be the final resting 
point of the image. 

 Note: You can make the final bounce back into place 
take longer (more frames) to make the object seem like 
it’s slowing down, by inserting the keyframe in this step 
farther down the Timeline. 

5. Select the keyframe labeled Back. 

6. In this keyframe, click the symbol instance on the Stage 
and use the arrow keys to move the instance 5–10 key 
presses back in the direction it came from. 

7. Create motion tweens between all the keyframes. 

8. Add an actions layer to the top of the Timeline.  

9.  On this layer, insert a keyframe after the last frame and 
add a stop action (Figure 19). 

 The Timeline should appear as it does in Figure 20. 

9. Save the movie. 

10. Select Control > Test Movie to test the movie. 

11. Select File > Close to close the preview window. 

 
Figure 18 Frame label 

 

 
Figure 19 Actions panel 

 

Figure 20 Final timeline 
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Publish your movie 
When you’re ready to deliver your movie to an audience, you can publish the Flash document (FLA file) for 
playback. The Publish command creates a Flash SWF file (playable with Flash Player) and an HTML document that 
inserts your Flash movie in a browser window. For viewers who do not have Flash Player installed, you can select to 
publish the FLA file in alternative file formats—GIF, JPEG, PNG, or QuickTime—with the HTML needed to 
display them in a browser window. 

When you publish HTML with your movie, Flash also creates a file called AC_OETags.js. This JavaScript file lets 
your SWF file play automatically in certain browsers (called active content-compliant browsers) that would 
otherwise require a site visitor to click to play your movie. To avoid this problem, upload AC_OETags.js to your 
site in the same location as the HTML file that hosts the movie. For more about this issue, visit 
www.adobe.com/go/activecontent. 

1. Select File > Publish Settings to open the Publish 
Settings dialog box (Figure 17). 

2. Use the Formats tab to determine which file formats to 
output when you publish. 

3. Use the Flash tab to determine which Flash Player you 
are publishing to (Figure 18). If you think your 
audience might not have the latest player, you might 
want to select an older player from the Version menu. 

4. Select Generate Size Report to see a detailed report of 
size for each asset in your movie. 

5. Select Protect From Import to prevent anyone from 
importing your SWF file into Flash and converting it 
back to a FLA file. 

6. Select Compress Movie to reduce the file size of the 
exported movie.  

Figure 17 Publish Settings dialog box 

 

 
Figure 18 Flash tab of Publish Settings dialog box
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7. Use the HTML tab to control settings for the HTML file 
(Figure 19). 

8. Deselect the Loop option if you want your movie to play 
through only one time and stop. 

9. To publish your movie, click the Publish button. 

 
Figure 19 HTML tab of Publish Settings dialog 
box 
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Analyzing and scripting a digital narrative 
Student name: _________________________________________________ Date: _______________________ 

Narrative description 
Answer the following questions to help you set up your narrative. 

What type of narrative is it? ______________________________________________________________________ 

____________________________________________________________________________________________ 

Who is the primary audience? ____________________________________________________________________ 

____________________________________________________________________________________________ 

What is the message of the narrative? (Summarize in one sentence.) ______________________________________ 

____________________________________________________________________________________________ 

How does the narrative enhance the overall goals of the site? ___________________________________________ 

____________________________________________________________________________________________ 

Write a narrative that stays within the following criteria: 

• The audio recording for the narrative does not exceed 45 seconds. 

• The length of the movie does not exceed one minute. 

• The number of written and spoken words is fewer than 50. 

• The narrative contains at least one transition effect. 

• The narrative contains at least one filmmaking technique. 

• The narrative contains no more than five different filmmaking and transition techniques. 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 
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____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 
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Are the transitions smooth? If not, how can they be made smoother? ______________________________________ 

____________________________________________________________________________________________ 

Does tweening occur as expected? If not, how can the problems be fixed? __________________________________ 

____________________________________________________________________________________________ 

Is the size of the finished movie acceptable for the intended delivery? _____________________________________ 

Comment on any over- or under-use of animation, sound, transitions, or effects. _____________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

Usability 

How easy is it to navigate through the narrative? Is the navigation predictable and easy to use? Is the text readable? 
Do images and other media elements load in a reasonable time? Is it easy to follow and understand animations? 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

Narrative criteria 

Does the narrative fall within the required time and word limits? _________________________________________ 

Does the narrative include at least one transition and filmmaking technique?________________________________ 

Does the narrative exceed five uses of effects or filmmaking techniques? __________________________________ 

Does the audio narration exceed 45 seconds?_________________________________________________________ 

Does the narrative stay within the one-minute time limit? _______________________________________________ 
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 Activity 2.5 guide 

© 2007 Adobe Systems Incorporated Planning a home page 1 

Planning a home page 
The home page storyboard includes a design layout (graphics, text, and site navigation scheme) to make creating the 
home page easier. Use the following guidelines to help you create the storyboard of your home page on paper. 

Graphics 
Draw rectangles on the page to indicate the size and placement of graphics. Label these rectangles with the 
filenames of the graphics they represent. 

• What graphics will you include on the home page? 

• Where will you place the graphics on the page? 

Text 
Draw rectangles on the page to indicate the text placement. Label these rectangles with content descriptions. 

• What text will you include on the home page? 

• Where will you place text on the page? 

Navigation 
Draw a rectangle to indicate the placement of the links to other pages. Label this rectangle with the names of the 
other pages. (You will build graphical buttons for these links later in this course.) 

• According to your flowchart, the home page directly links to what pages (what are the menu items)? 

• Where will you place these links on your home page? 

Color 
Indicate the background and text colors on your storyboard. 
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Usability 
Student name: _________________________________________________ Date: _______________________ 

URL: _______________________________________________________________________________________ 

Site name: ___________________________________________________________________________________ 

 

What types of navigation elements are used: buttons, hyperlinks, images, something else? One type or several? 
Describe each type of navigation element. 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

 

As you navigate, how many clicks does it generally take to get to information you are seeking? 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

 

As you navigate, do you get to the information you are expecting? 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 
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Is the site structure apparent? 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

 

How long does it take for pages to load? 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

 

Is the text readable? Is the text uniquely styled? If so, does the styling add value to the purpose? 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

 

What are the elements of the visual layout? How do these elements make it easier or more difficult for visitors? 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 
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Are there clear titles, headings, or other visual elements that specifically help organize the information? 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 
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