
Homework Five- Using the Loader Class to Design a Web Site 
Designing a site using the Loader class allows you to design large rich-media 
web sites without having unreasonable download times. You do this by 
“chunking”, designing so that instead of having one big movie that downloads 
all at once, you make several small movies that download at different times, 
and are stacked on top of one another or replace one another. The movie that 
loads first is called the base movie and all other movies stack on top of that like 
layers in Photoshop. 

In this exercise, we will create an entire 12 “screen” web site from scratch by 
creating a base movie which uses the Loader class and new URL request 
method to load section movies. Within three “section” movies we will utilize a 
“goto” structure to navigate to various frames within each movie.  

Note: All concepts and ActionScript in this assignment are based on exercises in 
chapter 12 of the required textbook. If you have a hard time understanding the 
concepts, please review the chapter and see me in lab or office hours. 

Upon completion, you will have the following files: 
lastname_firstname.fla 
main.fla 
section_one.fla 

section_two.fla 
section_three.fla 

 
You will publish each of these into a folder that you either upload to your website 
or attach to an email to jdiamond@santarosa.edu 
 
The final published folder will contain: 
lastname_firstname.html 
lastname_firstname.swf 
main.swf 
section_one.swf 

section_two.swf 
section_three.swf 
AC_RunActiveContent.js 

 
You can see a demo of this assignment here 

Before you begin 
1. Your code must be letter perfect. One keystroke error can stop the movie 

from working. 
2. All text fields must be static text fields unless otherwise indicated. While 

this is the default setting, Flash remembers your last text field setting and 
uses that for the next text field you create. 

3. The names of your section swf, buttons, and labels must match. It is 
required by the parameters (event.target.name) that appear several times 
in the ActionScript. Now let’s get started. 
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Create a new movie (this is your “base” movie) 
1. Create a new ActionScript 3.0 movie. Save as lastname_firstname.fla  
2. Open the Movie Properties panel and set the dimensions to 780 x 540, 

choose a background color and close the panel. Leave the fps at 12.  
3. Name layer one actions. 
4. Create two new layers and name them nav bar and background. 

Create the mcMain Movie Clip 
1. Select Insert> New Symbol> Create New Symbol> Movie Clip and name it 

mcMain. 
2. Within this movie clip, create a background that includes an area for a 

banner, logo, navigation, web address, and unique content area. See screen 
shot here. Notice 
only the web 
address at the 
top, the 
navigation on 
the left, and the 
home and 
contact us 
button areas 
have content in 
them. These will 
be built out in 
subsequent 
steps. The 
remaining areas 
will be populated 
from content in your main and section movies that you will build later in this 
project.  

3. In the Library drag mcMain on to the background layer of the main timeline 
and lock the layer. 

Create the mcNav Movie Clip 
1. Select Insert>New Symbol>Create New Symbol>Movie Clip>Name> mcNav. 
2. Name the top layer of the mcNav movie clip actions and add frames to 40. 
3. Create two additional layers and name them from top to bottom, labels and 

buttons. 
4. In the labels layer, create keyframes on frames 10, 20, 30, and a frame on 

frame 40. 
5. With the label layer selected, create frame labels in the Property Inspector: 

a. Frame 0- start 
b. Frame 10- section_one 

c. Frame 20- section_two 
d. Frame 30- section_three 
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Create buttons that will nest inside mcNav 
1. Select Insert> New Symbol> Create Button>btnSectionOne. 
2. Create three layers: arrow, text, and hit. 
3. On the arrow layer create a small triangle. 
4. Select the text tool and make sure it is set to Static Text for this and all text 

fields in this project. On the text layer write “section one” in a color that will 
contrast with the nav region background color of the mcMain movie clip.  

5. Insert a keyframe on the over state of the text layer and change the text 
color of “section one”. 

6. Insert a frame on the down state of the text layer. 
7. Select the hit layer, draw a rectangle over the text and drag the keyframe to 

the hit state. It should be only over the hit state. Your button timeline should 
look like the one here. 

8. In the Library select the 
btnSectionOne, right-click 
and choose Duplicate two 
times and rename them 
btnSectionTwo and btnSectionThree. 

9. Edit both symbols and change the text to section two and section three 
accordingly. Make sure to change the text in both the Up and Over states. 

Bring the buttons into mcNav and complete mcNav 
1. Double-click on mcNav in the Library and drag one instance each of 

btnSectionOne, btnSectionTwo, and btnSectionThree from the Library onto 
the center of the stage in frame one of the mcNav buttons layer.  

2. Assign instance names to the buttons: 
section_one, section_two, and section_three.  

3. Your mcNav stage should look similar to this.  
4. Add keyframes to frames 10, 20, and 30 of the 

button layer. 
5. Click on frame 10 of the mcNav timeline, 

select the section_one button, and in the 
Property Inspector, choose Tint from the Color 
menu and change the color of that instance 

only.  
6. Click on frame 20 of the mcNav timeline, select the section_two button, and 

in the Property Inspector, choose Tint from the Color menu and change the 
color of that instance only. 

7. Click on frame 30 of the mcNav timeline, select the section_three button, 
and in the Property Inspector, choose Tint from the Color menu and change 
the color of that instance only. 

8. Click on the keyframe in frame 1 of the actions layer. Open up the 
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ActionScript (AS) editor and place the lines of ActionScript on the following 
page: 

 
9. Your mcNav timeline should look like this: 

 

Complete the Main Timeline and Test Movie 
1. From the Library drag an instance of the mcNav symbol on to the nav bar 

layer of the main timeline. 
2. Select the keyframe on the Actions layer, right-click and select Actions. 
3. With the Actions panel open write the script here: 

 
4. Select File> Import> Open External Library and navigate to the 

Loader_final.fla file  inside the Loader folder of Flash CS3 Professional HOT 
chapter 12 exercise files (CD). 

5. Drag a copy of mcHome and mcContact onto the nav bar layer and position 
them near the bottom of the screen. 

6. Double-click on the instance of mcContact on the nav bar layer of the stage. 
7. Right-click on frame one of the actions layer and select Actions 
8. Change the email address to your email address and remove ,  “_blank” in 

line three and close the Actions panel. 
9. Save your file and TEST YOUR MOVIE. It will only work though when you 

turn off strict mode(see below). Note: Ignore “Error #2044: Unhandled 
IOErrorEvent:. text=Error #2035: URL Not Found.” This is because you 
haven’t yet built main.swf 

Turn off Strict Mode 
If you get compiler errors that you cannot figure out, turning off strict mode will 
make things easier. This will not fix keystroke errors but does deal with the error 
“1119: Access of possibly undefined property myLoader through a reference with 
static type flash.display:DisplayObjectContainer.” 
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Select File> Publish Settings 
1. Click the Settings radio 

button 
2. Deselect the checkbox 

“Strict Mode”. 

 

 
 

Designing the “main” and “section” movies 
In an actual site, creating content is of course one of the largest tasks. In 
building out this structure however, it is very simple.  

1. With your lastname_firstname.fla still open save the file as main.fla 
2. Right-click on frame one of the actions layer and delete the existing script. 
3. Replace it with the following script that utilizes the “goto” method to navigate 

within each section. We will make this functional in subsequent steps. 

 
4. Delete the nav bar layer from the main timeline 

Creating the content and navigation controls for the movie 
1. Add two layers above background- banner/logo/buttons and content 
2. Create a banner and logo that is unique to this movie and place them in the 

top areas (see sreenshot) 
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The purpose of this is like departments in a department store. While the 
name of the store may be Macy’s (for example), each department may have 
a logo or welcome message of its own. This becomes an indicator to the user 
where they are within your website. 

3. On this same layer, place a back and forward button that you either create or 
use by accessing File> Import> Open External Library> slideshow_Final.fla 
and drag both btnBack and btnNext. 

4. Name the btnBack instance back_btn. 
5. Name the btnNext instance next_btn. 
6. Lock the banner/logo/buttons layer 
7. With the frame one of the content layer selected select the text tool and write 

“This is screen one of the Main movie”. 
8. Hit the F6 key twice to add two new keyframes. 
9. On frame two change the text to “This is screen two of the Main movie”. 
10. On frame three change the text to “This is screen three of the Main movie”. 
 
Obviously, when creating a large website each of these screens would be 
populated with images, catalog items, etc. but for now we have created a 
functional structure. 

Removing some elements from the mcMain background. 
Our final step in modifying our main and section movies is to remove some 
navigational elements from the mcMain background so they do not cover up the 
base movie (lastname_firstname.fla) that is located under the section movies. 
 
1. In the Library double-click on mcMain and continue to double-click until you 

remove the left sidebar, the 
bottom bar and the top bar 
color shapes (see red arrows 
in image here). The 
remaining sections, logo, 
banner and main content 
area are all that is left of the 
color shapes from the orig
mcMain.  

inal 

t 

2. Go back to the main timeline 
and your movie should look 
something like this. Notice 
the grey area. This is the 
color of the background of the stage and indicates that there is no conten
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here. These areas will be populated by the base movie and will show throug
all section movie

h 
s. 

3. Now test your movie by selecting Control> Test Movie. You should have a 
fully navigational section movie. Save your movie. 

4. Open your base movie (lastname_firstname.fla) select Control>Test Movie. 
You should see your 
navigation on your left and 
your main movie complete 
with main content, banner 
and logo. It should look 
similar to this screen shot. 
Close your base movie. 

5. From this point,  it is easy 
to create the section_one, 
two, and three movies 

6. Create your remaining 
section movies 

7. With main.fla open save it 
as section_one.fla 

8. Unlock the banner/logo/button layer, change the logo and banner and re-lock 
the layer. 

9. Select the content layer and change the content on frames one two and three 
to say “This is screen one of the Section One movie”, etc. 

10. Save and publish your section_one.fla file. 
11. Then save as section_two.fla and repeat steps 2 and 3 above. 
12. Then save as section_three.fla and repeat steps 2 and 3 above. 

Testing your final product 
1. Open your base movie (lastname_firstname.fla) and select Control> Test 

Movie. You should have a fully functional website with a total of 12 different 
screen views reflecting the content inside your main and section movies that 
are being loaded on top of this base movie. 

 
The final project expands upon these same concepts and adds a pre-loader, a 
password entry page and sound/video files. 
 

1. Some ideas for movies include:  
• Idea 1- Create a tutorial for first-time readers. Illustrate the 

letters A, B, and C. Give an illustration and an appropriate 
sound that announces the letter and/or the name of the 
object when you click on that letter/illustration.  

• Idea 2- Create an animated resume.  
• Idea 3- Create an online tutorial.  
• Idea 4- Create an online gallery. 
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2. Design Assessment Rubric  

a. Typography: Titles, subheadings, and text should be 
displayed in sizes that reflect the content hierarchy.  

b. Images/Sounds: All images and sounds should be 
appropriate to the content of the site. Images should be 
displayed with appropriate resolution.  

c. Layout: The layout should follow a consistent pattern  
d. Hyperlinks: ALL should function correctly.  
e. Navigation: The site should be easy to navigate so that 

information can be found easily.  
f. Make sure that you spell check your work.  
g. With menus, back button must send user to the menu rather 

than an opening animation repeatedly.  
h. All branches of a menu must be functioning. 
 

No submissions will be accepted past the due date.  
Bring in to class on the final day or email all the working files to 
me. Subject: Your name Flash A Final Project 
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