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Flash CS 3 Essential Training Notes 

Week 1- Getting Started 

1. Creating a new document 
a. By using the Welcome screen- there are a variety of choices including new, from 

templates 
b. Selecting File> New (there are both General and Template tabs)  

2. The default workspace 
a. The window in the center of the screen is called the Document window. It is also 

referred to as the Stage 
b. Above the Stage is the Timeline 
c. Below the main Document window is the Property Inspector 
d. To the left of the main document window is the Tools panel 
e. To the right is the Panel wells 

3. Customizing your workspace 
a. The current version of the Tools panel is designed to be a single column but you 

can return to a 2 column display by clicking in the gray area above the Tools 
panel  

b. You can minimize panel groups to icon and text view by clicking on the gray bar 
above the panels 

c. You can tear the panels out of their docked positions and it behaves as a stand-
alone floating panel 

4. Reorganizing panels 
a. When you click on any of the tabs in any of the panel sets, it makes that tab 

become the foreground tab in the panel set 
b. You can pull individual panels into a stand-alone position or drag between panels 

to have a panel docked by itself between panels 
c. You can also restore, close, and rearrange single panels and whole panel groups  

5. Saving workspaces 
a. After rearranging your workspace you can save the new configuration by 

selecting Window> Workspace> Save Current 
b. You can rename and delete workspace by selecting Window> Workspace> 

Manage… 
6. Document tabs 

a. By default new documents are added as tabs to the Document window. You can 
control whether each new document appears as a tab or as a free standing 
window by selecting Edit (File on Mac)> Preferences>General> Workspace 
checkboxes 

b. By default, Test Movies will open in their own window. You can change this to 
open in tabs by going back to the Preferences dialogue box. 

7. Maximize mode 
a. If you resize or move your document window it might disable the Maximize 

feature in Flash. To restore this you can select Window> Maximize mode 
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8. Finding help 
a. The built in help system in Flash allows you to access a huge list of “books” 

including topics like Using Flash and extensive ActionScript help by selecting 
Help> Flash Help or by using the F1 function key shortcut 

b. There are a variety of online resources listed under the Help menu 
c. In addition, the Welcome screen provides access to many online resources 

Week 2 - Draw ing Essentials and Testing and Publishing File 

1. Drawing tool basics 
a. When you mouse over any tool you will see the keyboard shortcut equivalent for 

that tool. 
b. The context sensitive area at the bottom of the toolbar is known as the tool’s 

Options. It changes depending upon which tool you have selected.  
c. For many of the tools there is a circle icon as one of the Options. This is the 

Object Drawing mode. This makes shapes behave as if they are separate objects 
even though they are stage-level shapes. 

d. Use the Selection tool to click and drag over selected items on the stage to edit 
or delete these selections. 

2. Drawing with the Pencil and Line tools 
a. The pencil drawing mode has three options; Ink, Smooth, and Straighten 
b. You can also control many of the Pencil and Line tool properties from the 

Property Inspector including Stroke color, Thickness, Line style, Scaling, 
Smoothing settings, Endpoint appearance (Cap, Join, None), and Custom 
settings, which allows you to customize the default line styles. 

3. The improved Pen tool 
a. Allows you to work with Bezier curves. When you click it leaves an anchor point 

for each click. 
b. When you click and drag it creates control points around each point and creates 

a curve between each point. 
c. Use the sub-selection tool to move individual pen tool points 
d. You can Add, Delete, and Convert Anchor points using the options available 

when you hold down the Pen tool. 
e. When using the Convert Anchor point, clicking on any point with handles 

converts it to a corner and clicking and dragging on any corner converts it to a 
curve with handles. 
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4. The Quick Color tools 
a. In the Tools panel there are two color swatches; one for stroke and one for fills. 

You can also choose no color. 
5. Drawing with shapes 

a. Holding down the Rectangle tool reveals a variety of other shapes you can draw 
b. Holding down the Shift key while drawing constrains your shape to a square, 

circle, or equilateral triangle depending on the tool you have selected. 
c. The Polystar tool provides options that allow you to adjust numbers of sides and 

different shapes. 
d. The Rectangle and Oval Primitive Tools are new to Flash CS3. They allows you to 

separate the corner radii into unique settings (for creating Tabs, Pie Pieces, etc.) 
6. Selecting content 

a. Click and drag with the Selection tool 
b. Single or double clicking allows you to either select fills or strokes individually or 

in total. 
c. The sub-selection tool allows you to select any object revealing it anchor points. 

7. Manipulating lines and fills 
a. Use the sub-selection tool and examine the vertices 
b. Use Selection Tool 

i. Click and drag a stroke to re-shape 
ii. Click and drag a corner point to adjust corners 

c. Use Pen Tool to select vertices and re-shape both strokes and fills 
d. Eyedropper- Use it to see info on strokes and fills in the Properties panel 
e. Changing Stroke to Fill- Modify> Shape> Change Stroke to Fill  

8. Painting with brushes 
a. In Options at the bottom of the Toolbar you can change Brush size and Shape, 

as well as find five different Paint modes 
i. Paint Normal- paints over fills and strokes  
ii. Paint Fills- only covers the fills and leaves stroke untouched  
iii. Paint Behind- paints behind the object you are painting 
iv. Paint Selection- paints only the areas selected 
v. Paint Inside- paints inside the areas selected  

9. Erasing content- very similar to painting including five Erase modes 
i. Erase Normal- erases over fills and strokes  
ii. Erase Fills- only erases the fills and leaves stroke untouched  
iii. Erase Lines- only erases the strokes and leaves fill untouched 
iv. Erase Selected Fills- erases only the areas selected 
v. Erase Inside- erases inside the areas selected 
vi. Faucet mode- erases entire color of a particular area 

10. Understanding drawing modes 
a. Traditional mode- stage level objects either merge similar colors or break 

different colors apart 
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b. Object drawing mode- when selected and placed on top of other shapes even on 
the same layer, it remains separate. You can arrange these items front to back 
and in many ways it operates as a grouped object 

i. Double-clicking will allow you to edit Object mode objects 
11. Understanding document settings 

a. Modify> Document settings includes File dimensions, Stage color, Frame rate, 
Ruler Unit, Insert a Title and Description for search engines, and access Publish 
Settings 

12. Testing buttons and movie clips 
a. By default you cannot see a button in authoring mode but you can change this 

by selecting Control> Enable Simple Buttons (I advise against this) 
b. You can play inside a movie clip by going inside the MC and hitting the Return or 

Enter key 
13. Testing your movie 

a. Select Control > Enter or use the keyboard shortcut Control/Enter 
b. Bandwidth Profiler- Gives you a graph that shows how much content has been 

loaded. In addition you can adjust the download setting by selecting View> 
Download Settings, to simulate the speed a user may be downloading 

c. Show redraw regions informs you what regions have a lot of movement that 
need to be redrawn on the users display 

14. Publishing your movie 
a. File > Publish Settings  

i. Flash Tab allows you to control the Flash player version, Load Order, 
ActionScript version, Generate size reports- a text file that displays size of 
assets in your file, Protect from import, set passwords, adjust global 
image and audio file settings 

ii. HTML controls use of template HTML pages, dimensions, playback 
options, quality, window mode, and the alignment of the Flash file within 
the html page 

iii. Formats allows you to choose what files you want to create upon 
publishing 

iv. Publish Preview allows you to choose whether you preview a standalone 
Flash file or embed the Flash file in a browser 

Week 3- Animating in Flash 

1. What is a keyframe? 
a. One way of representing an object’s information through time. An object can be 

on the stage for 100 frames but if there is one frame, we know all that object’s 
information until we encounter another keyframe 

b. When I select Insert > Timeline > Keyframe and add another keyframe, I can 
change the information of the object such as its color, position, size, etc. 
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c. When I create a tween between these two keyframes I can move the object but 
the program is defining how to get from the first to the second keyframe. Only 
keyframes can introduce new author defined information. 

2. Using frames and keyframes 
a. Add frame (F5) - Select Insert > Timeline > Add frame. You do not have to have 

the same number of frames in every layer. If you want to add to all layers by 
shifting and drag select multiple layers 

b. Add keyframe (F6)- Select Insert > Timeline > Add keyframe. Doing it without 
content would be Add Blank keyframe (F7) 

c. Deleting- The keyboard shortcuts are the same as adding with the addition of 
the Shift key (for example Delete keyframe is Shift- F5). You can also get all this 
information from the context sensitive menu 
by right-clicking (control-click on the Mac) 

3. Working with multiple frames  
a. Editing content with more than one frame- inserts a marker above the frames to 

show where you will be editing. The items on the stage should all be selected 
when you select all the frames. 

b. Onion-skinning- allows you to see the position of all the 
keyframes on the stage. Onion-skinning does not appear on 
locked layers. 

4. Copying and pasting frames- Different than standard copy. Select > Edit >timeline > 
Copy frames. Once ready to paste select Edit > Timeline > Paste frames or use context 
sensitive menu.  Keyboard shortcuts are useful: 

a. Copy- (shift- Control- C) (option-command- C on the Mac) 
b. Paste- (shift- Control- V) (option-command- V on the Mac) 

5. Understanding scenes- Scene 1 is the default setup in Flash 
a. Multiple scenes are useful for authoring organization. When a swf file is rendered 

all the scenes are presented as one single swf with one continuous timeline 
b. Select Insert Scene. To see one scene you can select Control >Test Scene 

Week 4- Shape Tw eening 

1. Shape tweening 
a. Tweening from one shape into another (morphing). Often it is useful to 

transform a shape into a movie clip and entering symbol editing mode to create 
the shape tween. All tweens occur between keyframes. Successful shape tweens 
show up in a layer as green frames with a black arrow.  

2. Using shape hints 
a. You can use shape hints to assist in the shape tweening process. The process 

involves applying shape hints to the both keyframes where you want the shape 
hint to assist. Select Modify> Shape> Add Shape Hint. You can also use the 
keyboard shortcut Alt-Shift-H. The end result is that the shape hints allow you to 
guide Flash in the process of morphing between two keyframes.  

3. Tweening gradients 
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a. You can shape tween gradients as well. Best to make sure to create a shape the 
size of the full stage for good visual integration. Create the shape inside of a 
movie clip to allow the shape tween to play independently. (Reminder- movie clip 
timelines are independent of the movie or scene timeline.)  The example in the 
online video uses three keyframes to create a perpetual oscillating effect. 

4. Using Layers 
a. Similar to Photoshop- Pencil- layer is editable, Eye- indicates layer’s visibility, 

Lock-indicates whether you can edit the layer, Outline- view in outline form 
b. Name your layer by double-clicking 
c. Icon to the left launches Properties icon- Show, Lock, Type- normal, guide, 

mask, and outline color 
d. Guide layers- does not render when you publish your movie but Flash CS3 gives 

you the option to even publish hidden layer by going to the Publish Settings. 
Flash Tab > Options > Export hidden layers 

e. Mask layers- Any pixels you create will be defining the hole through which you 
look. It is its own layer and masks the content of the layer above it 

f. Cover the area up on the mask layer and then select this layer in the timeline 
window and change the Properties of the layer to a mask layer. When you lock 
both layers you can see what is shining through the mask  

5. Adding, deleting, and grouping layers 
a. Insert layer- goes above the layer selected 
b. Delete layer- select the layer you want and click the Delete icon 
c. Motion Guide layer- Like the mask layer, it affects the layer above it 
d. Grouping layers- create a folder and place the grouped layers together 

Week 5- Symbols and Instances/  Filters and Blend Modes 

1. Symbols overview 
a. Shapes compared to symbols. Editing shapes apply to that shape only. When you 

multiple copies of the shape, it adds to the file size. A symbol is a master copy of 
a shape. When you editing the Symbol properties it edits every instance of the 
symbol. You can edit a symbol by double-clicking, using the context sensitive 
menu, going to the Library, or going to the Modify menu and selecting Edit 
Symbol. When you edit an instance of the symbol in the Property Inspector, it 
only affects that instance. Be familiar with the differences of the following object 
types: Shapes, Drawing Objects, Primitives, Grouped objects, Text, and Bitmaps. 

2. Creating and editing symbols 
a. You can create a symbol from scratch by selecting Insert > New Symbol (F8). 

You choose between Movie Clip, Graphic, or Button symbol types. You edit the 
symbol in its own timeline. You can also create a symbol by selecting a shape 
already on the stage and selecting Modify > Convert to Symbol. When you edit a 
symbol from the stage by double-clicking, you see the other stage elements 
grayed out and edit the selected symbol in its position on the stage. 

3. Nesting and breaking apart symbols 
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Location of the 
gradient. Grab to 
move. 

Constrain scale. Drag in or 
out to decrease or increase 
the size of the gradient. 

Rotation. You 
can rotate up to 
360 degrees. 

a. Nesting symbols is used to control animations and to enhance ActionScript 
capabilities. You can nest a symbol into another symbol by dragging it from the 
Library into the timeline of the symbol within which it is nested. You cannot nest 
a symbol inside itself. If you want to change one instance of a nested symbol 
and not affect the master symbol, select the symbol on the stage and choose 
Modify > Break Apart. Now you can edit that instance of the symbol without 
affecting the master symbol. If you continue to break apart an instance of a 
symbol it eventually becomes a shape. 

4. Using the Color Mixer 
a. New to the Color panel are the spectrum mixer and the RGB color values. From 

the Type pull-down menu, you can choose Solid, Linear, Radial and Bitmap. 
When you choose Linear or Radial gradients you are presented with a color bar. 
Clicking on any point along the color bar adds an additional color to the 2 colors 
presented by default. Grabbing them and pulling away removes them. You can 
edit the colors by double-clicking on 
them. You can also 
slide them to adjust 
the transition point, 
and adjust the Alpha 
for each color. 

5. The Gradient Transform tool 
a. Use the Gradient 

Transform tool to 
reposition the 
gradient in 
relation to any 
object to which 
it is attached on 
the stage. The 
overflow tool in the 
Color panel can be used with the Gradient Transform tool to modify the gradient.  

6. Color swatches 
a. Solid colors are at the top with the gradients at the bottom. After creating a new 

color select the swatches panel and roll over to the right of the gradients. The 
cursor becomes a Paint bucket. Clicking in the empty space to the right of the 
solids or gradients stores your custom color accordingly. Use the Swatches panel 
options (top right corner) to save the colors as a .clr file. You can then add or 
replace the color set for any .fla file. Select > Load Default Colors to return to 
the 216 web safe default color set. 

7. Working with graphics 
a. Graphic symbol timelines are dependent on the number of frames in its parent 

timeline. In other words, if the Graphic symbol timeline has 25 frames, the 
parent timeline has to have that number of frames in order for the Graphic 
symbol to play until its end. Graphic symbol 



CIS 75.31A Notes    - 8 -         Introduction to Flash 
Santa Rosa Junior College Jeffrey Diamond 

instances cannot receive Instance names so they cannot be controlled with 
ActionScript. There is a pop-up menu in the Property Inspector that allows you to 
exert some control over the Graphic symbol.  

8. Using the Library  
a. The Library is where we organize our assets. 

You can keep track of your use count and delete 
unused items. You can organize items into 
folders or by file types. You can duplicate 
symbols. Select the Info button below the 
symbols to get the properties of 
an individual symbol. 

9. Transformation tools 
a. You can scale, rotate, skew, distort, and 

apply an envelope to shapes and symbols. You 
can do this in a number of ways; by using the 
Free Transform Tool, by right-clicking the 
object, or by going to the Info and Transform 
panels. 

10. Transformation panels 
a. You can transform shapes and symbols from the Property Inspector, the Info 

panel (width, height, x and y coordinates, and registration points), the Transform 
panel (scale, rotation, skew, constrain). You can copy the transformation from 
the panel and apply it to objects on the stage. You can use the Align panel to 
align and /or distribute top, left, and bottom edges both vertically and 
horizontally of any group of selected objects on the stage. You can also match 
the sizes and spaces of the selected objects. It will match to the largest object 
selected. The Align to Stage icon causes these modifications to be made in 
relation to the Stage itself. 

11. Transformation menu 
a. Modify > Shape > Expand Fills allows us to create custom insets. The Soften Fills 

option allows us to create custom feathered shapes. 
b. Modify > Combine Objects has four options 

i. Union- joining 
ii. Intersect- uses the top object to show only the area of the selected 

shapes that intersect. 
iii. Punch- uses the top object to punch out the area of the underlying object. 
iv. Crop- uses the overlapping area to preserve the underlying object. 

c. Modify > Symbol allows you to swap symbols and duplicate symbols without 
going to the Library menu. 

d. Modify > Transform allows you to rotate or flip a selected object. 
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12. Modify > Arrange allows you to adjust the z-axis of the 
selected items. You can also lock the selected items. Using 
blend modes 

a. Blend modes can only be applied to movie clips, and 
are often used with two images on top of each other 
to create various composite effects. This is useful for 
re-purposing jpgs so you don’t have to go to an 
image editing program and save as a ping to remove 
the background. 

13. Flash-specific blend modes 
a. Layer is essentially for pre-composing a movie clip so 

it can be composited correctly with other images on 
the stage. 

14. Alpha and Erase work in conjunction with the Layer blend 
mode when the Alpha or Erase is applied to movie clips 
within a parent movie clip that has its blend mode set to 
Layer. 

15. Using filters 
a. Can only be applied to movie clips, buttons, and text 

elements. Turn bitmaps and other shapes into MC symbols to 
provide access to filters. Specific filter options include blur x 
and y, strength, color, angle, and distance of drop shadow. 
Finally, you can copy the filter effects to other objects. 

 
16. Special filter options 

a. You can apply filters by knocking out the object (leaves a stroke), without seeing 
the object (Hide Object), and apply inner shadows, bevels, glows, etc. 

17. Animating filters 
a. You can use filters to hide the object and animate the shadow, bevel, or glow 

itself separately from the main object. In addition, you can use the free 
transform tool to skew and scale the object to add more interest to the 
animation. Good example is the walk cycle shadow. 

b.  

Week 6- Motion Tweening/  Timeline Effects/  Working w ith Bitmaps 

1. Motion tweening 
a. The most common animation technique in Flash because it is versatile. Use 

motion tweening to tween attributes of symbols, text, groups, and primitives. 
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This video both shows how to tween alpha, position, scale, and rotation 
attributes, it also takes a big step in assembling your final project. 

2. Copy and Paste Motion 
a. Reduce repetitive tasks by copying and pasting motion attributes from one tween 

to create a new tween. Shift-select the keys that have the tween, right-click 
(Control-click for Mac users) and select Copy Motion. Shift-select the two 
keyframes where you want to re-use this animation, right-click (Control-click for 
Mac users) and select Paste Motion. You can also choose which aspects of the 
tween will be pasted to the new target via the Paste Motion Special dialogue box. 

3. Motion guides 
Use motion guides to create a precise path along which your animation will follow. You 
can draw this path freehand for great flexibility. Add a motion guide to a layer by 
selecting the icon below the layers in the Timeline and clicking on the Motion Guide 
icon. The motion guide automatically becomes the parent of the layer selected. In 
addition the relationship is clear because the original layer is indented below the new 
motion guide layer. The guide layer is invisible upon export. You can use the Snap and 
Orient to Path option in the Properties panel (below) to make sure irregularly shaped 
objects follow the motion guide in a natural looking way. 

 
4. Custom easing 

a. Use simple Bezier curves to create customized graphs for easing properties in 
and out of animations. You can Ease Into or Ease Out of animations by default. 
You can also customize Easing values by selecting the Edit button to the right of 
the Ease slider (see image above) You can adjust the easing curve and apply the 
same easing properties to individual properties including Position, Rotation, 
Scale, Color, and Filters. You can also use one setting for all properties. 

5. Vector vs. bitmap 
a. Pixels- small squares of color arranged in a pattern of 72 pixels per inch-

Photoshop uses pixels (jpg, gif, png) 
b. Vectors are precise curves created by complex math- Illustrator uses vectors and 

requires more CPU processing 
6. Importing images and image compression 

c. To import you should be in an unlocked active layer. Select File> Import> 
Import to Stage (Command/Control R). Asset is added to the stage 

d. When you try to import the first file as part of a sequence, Flash asks if you want 
to import the entire sequence. When you choose to do this, it places each image 
on its own keyframe in the timeline. You can import sequences directly into a 
movie clip 

e. You get to the compression settings by selecting the image in the Library. Within 
the Bitmap Properties dialog box you will see the compression properties 
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currently being applied to the image. You can customize these settings within 
this window. Use the Test button to update the settings. By default the global 
compression settings for all imported bitmaps are handled in the Publish settings. 

7. Tracing bitmaps 
f. Tracing converts bitmaps to vectors. Select Modify> Bitmap> Trace Bitmap. You 

can control the Color threshold, Minimum Area, Curve fit, and Corner threshold. 
Select Modify> Shape> Optimize to reduce the file size of the vector shape. 

8. Breaking apart bitmaps 
g. Select Modify> Break apart to create an object that can be used to create 

patterns and fills. Once a bitmap on the stage is broken apart, you can use the 
Eyedropper tool to fill shapes with the bitmap pattern. You can also apply bitmap 
patterns from the Color panel without breaking them apart. Choose> Bitmap 
from the Type pull-down menu to display all the bitmaps in the Library. 

7. Animated masks 
h. We use a function to target each next section of the movie. In addition, we use 

an animated movie clip to cover each section. Finally we apply a mask the 
avalanche movie clip so we only see it appear when the user clicks on the button 
to send us to each different section 

Week 7- Buttons 

1. Select Control > Enable Simple Buttons to allow you to test buttons within the 
authoring environment. This needs to be disabled in order to edit buttons from the 
stage. Buttons have four keyframes in their timeline. Up, Over, 
and Down are self-explanatory. The Hit state determines which 
pixels will evoke a mouse response.  

2. Adding sound to buttons 
a. Use either the sync setting Event or Start for the sound added to a button. 

3. To create an invisible button you only have data in the Hit state. It appears translucent 
on the stage. Button instances can receive an Instance name for ActionScript control. In 
addition you can apply Blend modes and Filters to a button. 

Week 8- Movie Clips 

1. Working with movie clips 
a. Most versatile symbol timeline. They function like little Flash movies inside of a 

movie. Movie Clips have an independent timeline. Movie Clip instances can 
receive an Instance name for ActionScript control. In addition you can apply 
Blend modes and Filters to a Movie Clip. 

2. Animated buttons 
a. Drop an animated movie clip into the over state of a button for continuous 

animation in the over state of the button. In the process we create a triangle 
that is turned into a graphic symbol—no ActionScript so MC is not necessary. To 
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turn this triangle pointer into a staggered animation move the keyframes so the 
object fades in over multiple frames. . 

Week 9 and 10- ActionScript Basics (AS) 

 

1. Overview and interface elements 
a. Actions panel- Window > Actions (F9) 
b. Preferences accessible from this window 
c. Script assist makes it easier to write AS without mistakes 
d. You can use the index at the bottom of the book window to review the AS 
e. Output panel-  Helps to debug scripts 

2. Frame scripts, tracing, and comments 
a. Frame scripts- Passive experience occurring based on the playback head entering 

a frame 
b. Tracing- Allows you to trace information to the Output window. It doesn’t appear 

in runtime; only for diagnostic purposes. When tracing frame scripts they 
execute only once per keyframe visit 

c. Commenting- use // to disable code or to leave comments in your code. To 
comment out multiple lines of code start with /* and end with */ 

3. Simple navigation 
a. gotoAndStop and gotoAndPlay allow the playback head to navigate to a specific 

location and either stop at that frame (stop) or continue on (play).  
b. Frame numbers vs. frame labels- allows you to rely on labels which travel with 

the frame content, so regardless of whether you add or subtract frames from a 
timeline, it does not affect the functionality of the scripts. 

b. Stop actions are typically on the first frame of a section/scene 
4. Variable basics  

a. Variables are used to store information and 
you use them a lot. You can change the 
values of variables once they are declared. 

Choose which 
version of 
ActionScript you 
are writing 
These are your 

 
  
 

Customize 
the 
appearance of 
the 

 
  

You type 
your code 
in here 
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When typing variables in the AS window, help will appear each step along the 
way as you are typing.  

 
5. Function basics 

a. Code blocks that only run their code when the function is called. The 
advantages are numerous. 

i. You can write all your functions in one place and have them called on an 
as needed basis from anyplace else like a button, etc. 

ii. Functions can include entire sets of actions 

 
6. Buttons and EventListeners 

a. EventListeners are a way of handling and reacting to events like mouse clicks 
and calling functions when those events occur. 
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b. Here is the appearance of a typical function and eventListener where the 

contents of the function are not executed until they are called and the listener is 
added to the button which is told to listen for a mouse click before calling the 
function. 

 

Week 11- Working w ith Text 

1. Understanding text types 
a. Static text- is actually a graphic at runtime. There are no needs to embed fonts 

or compatibility issues. 
i. Property Inspector options include- URL link, ability to make the text 

selectable 
b. Dynamic text- when you want to exert ActionScript control over the text. 

i. Property Inspector options include- can apply Instance name for AS, 
change from single-line to multi-line field, add border, render as HTML 
(limited), and embed fonts which you must do to assure that the end-user 
sees the correct font display. The more fonts you embed, the larger the 
file size. 

c. Input text- Similar to dynamic text, and allows user input. 
i. Property Inspector options include- similar to dynamic text, but add the 

ability to limit the maximum number of characters the user can enter. 
2. Controlling text appearance 

a. When drawing a static text field, you are limited to a single line field as you are 
drawing. Do not use free transform tool to resize text elements. Instead, you can 
use the Selection tool (new to Flash 8). When drawing a dynamic or input text 
field, you can size your text field with a variety of parameters. 
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b. Font rendering menu 
i. User device fonts for small fonts (under 10 pixels) 
ii. Anti-alias for readability- Best for text, and renders the anti-aliasing 

comprised of color. This requires Flash Player 8 or better. 
iii. Anti-alias for animation- Best for animations, and anti-aliases in black and 

white. 
iv. Custom anti-alias- You can customize these settings. Make sure to use 

positive numbers. This requires Flash Player 8 or better. 
3. Simple text effects through tweening 

a. Motion tweening. As long as you use static text your file will render the same on 
any platform. Trick is to work with each individual character at a time, but first 
convert to symbol for ease of editing. 

b. Use the Modify> Break apart and distribute to layers options to isolate characters 
on their own layers. 

c. Easy to stagger the animation by moving the position of the keyframes. 
4. Adding text to a project file 

a. Create a new layer for text, add keyframes. 
b. Create a labels layer, and add keyframes in the same frames as in the text layer. 
c. Create an Actions layer that synchronizes actions with the text and labels layers. 
d. Importing Illustrator content allows us to create movie clips directly from the 

Import dialogue 
box, control 
position, and 
more. 

e. Use Shift-
Control 
(Command for 
Macs) to paste 
in place. 

f. Use Swap 
Symbols form 
the Property 
Inspector to 
speed up the workflow. 

g. When pasting in text from any text editing program, if the text is greater than 
the field to which you are pasting it, 
you must use the Text> Scrollable 
command to preserve the size of the 
text field that you created on your 
stage. 

5. Spell-checking and Find and Replace 
a. Find and Replace is a very valuable 

tool that allows you to search for and 
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replace text, fonts, colors, symbol, sounds, video, and bitmaps.  
b. Spell check allows you to customize dictionaries, find duplicate words, and more.   

Week 12- Sound  

1. Adding sound to the timeline 
a. First step is to import a sound. You can import file types including wave, aiff, 

mp3, etc. Only mp3s can be added from an external source at runtime. You can 
add a sound to the timeline by dropping it on the stage. It will appear on the 
layer you selected in the timeline. 

2. Adding basic effects to sounds 
a. You can apply preset effects to a sound from the Property 

Inspector. In addition, you can customize the sound 
envelope by selecting Edit next to the presets in the 
Property Inspector. Within the Sound Envelope you can 
adjust volume, fade, pan, and clip the sound as well. 

3. Sound sync options 
a. Stream- Allows sound to play while the sound is downloading progressively. 

Avoid repeating or looping with Streaming. 
b. Event- Has to fully download before it begins to play and is useful for shorter 

sounds. You can loop this type of sound. 
c. Start- Will only trigger a sound when a sound has already completed. This makes 

it useful for interactions like a button press. 
d. Stop- Silences a sound. 

4. Sound compression basics 
a. Global settings are set in the File> Publish Settings options. Within these global 

settings, you can customize different settings for Stream and Event. Select the 
sound in the Library to set the quality for each sound on a case by case basis. 

Week 13- Components and Forms/ Video  

1. Components overview 
a. Adds interactivity without using ActionScript, although AS can be added to 

increase the functionality. Two places to look for free components are the Flash 
Exchange. Flashloaded offers excellent components at a cost. There a re three 
ways to configure components- with ActionScript, through the Parameters tab of 
the Property Inspector, and with the Components Inspector which is a separate 
panel. 

2. Adding a UIScrollBar component 
a. Is used when you want text in a dynamic text field to scroll. In order for it to 

work, you need to give your dynamic text field an instance name. Drag and drop 
the UI scrollbar onto the dynamic text field. If you drop the scrollbar onto the 
stage and miss the text field, use the Parameters tab to assign a 
scrollTargetName to create the relationship between the scrollbar and text field. 
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3. Using a Loader component 
a. The Parameters tab references the ability to automatically load, maintain the 

aspect ratio, and scale your content. Use the source field to point to the image 
you want to load. 

4. Embedded vs. external 
a. You can get video into Flash either by encoding the video directly into the SWF 

(generally not recommended) or by encoding the video as an external FLV file. 
Unless you are using a special Flash Media Server, your FLV files will 
progressively download into your Flash file. With progressive download you can 
only jump around up until the present point—you cannot jump forward. 

5. Embedding videos with the Flash Video Encoder 
a. The Flash Video Encoder ships with Flash has several facets: 

i. Video Exporter will be covered in the next section. 
ii. Integrated video encoder which allows you to choose how you want to 

deploy, embed, edit, split, crop, and adjust frame rate, and more, to the 
video. You can also adjust the audio, and choose either a custom preset 
video encoding profile or create your own profile. 

6. Encoding external FLVs with optional cue points 
a. The Flash Video Encoder allows you batch process videos. Settings include the 

abilities discussed in the prior section. Cue points are available here—they allow 
you to create a location in the video to which the user can navigate. This allows 
you to synchronize actions with the movie playback. These points are embedded 
in the FLV file and can be used wherever the FLV file is deployed.  

7. Playing external videos with the FLVPlayback component 
a. Drag FLVPlayback component from the Component Panel.  The Parameters tab 

allows you to first select the source of your video and then adjust the skin, 
alpha, background color, and volume. 

Week 15- Integration 

8. The story so far 
a. Interface, customization, 

drawing, layers, keyframes, 
guides, masks, symbols, 
tweens, copying attributes, 
import features, filters, trace 
bitmaps, static and dynamic 
text, as well as basic 
navigation. 

9. Publishing your site 
a. File> Publish Settings. Format 

section- default name is 
derived from the file name 
and is saved in the same 
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directory as the FLA file. Flash Settings- There are a variety of settings you can 
customize including protecting the file from being imported by an end user, 
compressing the movie which requires Flash Player 6 and above, omitting trace 
actions which makes sure your output window does not open and adjusting the 
image and sound compression settings globally. HTML Settings- Make sure that 
Detect Flash Version checkbox is enabled. 

4. Importing Photoshop files 
i. Flash CS3 allows you to import psd files with a variety of options. You can merge 

and rename layers, bring in layer styles, flatten images, create movie clips for 
layers, provide instance names, control its registration point, keep text editable, 
control the publish settings, convert layers to layers or keyframes, adjust the 
stage size, or keep all of the layers intact. 

5. Importing Illustrator files 
j. Flash CS3 allows you to import ai files with many options. You can retain editable 

paths or rasterize the paths as bitmaps, create movie clips for paths, provide 
instance names, control registration points, keep text editable, convert paths to a 
single Flash layer, discrete layers or keyframes, and adjust the stage size. 

Extras- Flash User Experience Best Practices 

1. Why user experience is important 
a. Up to 30% of web transactions end up in failure for a variety of reasons. Some 

reasons include- the process of adding shipping and tax to a transaction occur 
over multiple pages and when the end-user gets to the final screen and they see 
the final price they abandon the transaction. Another example is the use of 
image verification tests to eliminate spam bots causes failures on the end-user 
experience. Also, many websites require the use of specific browsers. The key to 
a successful user experience is that it meets the exact needs of the user. See the 
URL for more specific information. www.nngroup.com/about/userexperience.html 
In addition other factors, including simplicity, elegance of design, and a seamless 
merging of all services offered with the interface design. 

2. How Flash applications differ from HTML 
a. HTML sessions include multiple pages, user sessions may expire, and there is a 

measureable moment of stress when navigating between pages.  
b. Flash sites are a consolidation of single screen applications, they retain their 

content offline which is stored in your cache, it is easier to maintain the flow 
across the site, and information is retained easier. Some good examples of the 
difference between a typical html page and a typical Flash page include 
https://reservations.synxis.com/lbe/rez.aspx?chain=5185&hotel=10214&lang=1
&src=hotel  (html) vs. 
https://reservations.ihotelier.com/onescreen.cfm?hotelid=2054&languageid=1&r
ezT=2054 (Flash) 

3. Examples of problematic Flash user experiences. For example, Flash does not have a 
working back button by default. Another example is if the end-user is required to have 

http://www.nngroup.com/about/userexperience.html�
https://reservations.synxis.com/lbe/rez.aspx?chain=5185&hotel=10214&lang=1&src=hotel�
https://reservations.synxis.com/lbe/rez.aspx?chain=5185&hotel=10214&lang=1&src=hotel�
https://reservations.ihotelier.com/onescreen.cfm?hotelid=2054&languageid=1&rezT=2054�
https://reservations.ihotelier.com/onescreen.cfm?hotelid=2054&languageid=1&rezT=2054�
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the latest version of Flash and there’s no flash detection JavaScript that make sure that 
the end-user does have this latest version. In this case, the Flash website may render 
very differently in an older version of the Flash player. Check out Robert Hoekman’s 
tenets of design at http://www.rhjr.net/theblog  

4. Examples of effective Flash user experiences 
a. Here are set of exemplar Flash shopping cart demos- 

b. Some exemplar Flash animations engage the user--for example some data 
visualizations.  

http://www.visokio.com/ffsection/demos.cfm  

5. Using wireframes and screenflows can help you map out how a user is going to get from 
the beginning of the transaction process to the end of the transaction process. Basic 
strategies include: start with a one page story about your application; no technical details, 
just the soul of it. Some programs that are useful for flowcharting include Microsoft Visio 
(Windows) and OmniGraffle (Mac). Here is an example of a screenflow. 

 
6. Best practices  

a. Build the simplest thing you can build.  
b. Never build ahead of user feedback.  
c. Continue to simplify- remember the web is 100% self-service.  

7. Standard UI widgets vs. Flash UI widgets- The Flash widgets work differently than the 
standard browser widgets—for example scrollbars. Here is an example of one- 
http://www.elizabethtown.com/home.html General rule of thumb is that you don’t want to 
stray too far from the norm. Entertainment sites are expected to be more “edgy”. You can 
always use the standard UI components that Flash ships or you can use other custom UI 
components found at sites such as http://metaliq.com/mCOM/  

http://www.rhjr.net/theblog�
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8. User-testing essentials  
a. Start by creating simple wireframes and screenflows  
b. Use a variety of people (80-20 rule) but keep the group small and take notes on 

what they find confusing. Do not try to guide them. Steve Krug’s book on usability is 
an excellent resource http://sensible.com/ 

Extras- Flash P layer Detection and HTML Tricks 

You can find a sample test script which 
lays out what types of questions you should ask your users. 

Effective Flash Player Detection 
1. When to instruct users to update their Flash Players 

a. The first basic rule of thumb is that if it cannot be done with the version that the 
user has they should be required to get the version they need. Generally, though 
it is a good idea not to require the end user to download a newer version of the 
flash player if the flash application is not using new components. If it doesn’t 
help the user, don’t do it.  

b. Always use a Flash player detection method so the end-user knows what they 
are supposed to do. 

2. Implementing the Flash CS3 detection scripts 
a. The Flash player detection kit that ships with Flash CS3 is one of the most 

effective methods of detecting what version of the Flash player the end user has. 
To implement the Flash player detection select file, settings and select the HTML 
tab right below where it says Template. Make sure there is a checkmark in the 
check box that says “Detect Flash Version”. 

b. There are multiple sets of JavaScripts that are created on the HTML page to 
complete the Flash player detection process. This includes checking for various 
Flash player versions, and several scripts that are in the No Script tags to check 
in JavaScript is turned on and to show alternate content on the screen if either 
Flash or JavaScript are turned off. 

3. Choosing appropriate and effective alternate content 
a. Keep the error message short and sweet.  
b. Offer links to the most popular content on your site. 
c. Provide an option to email the webmaster. 
d. You can change the default alternate content on the HTML page that is 

generated when you use the Flash Player Detection Kit. 
4. Using Flash Player Express Install to handle upgrades 

a. This is built into the Flash application and allows the user to upgrade to the 
necessary version of the Flash player. 

b. You can find good articles on Best Practices for Flash Player Detection here as 
well as a link to download the FDK. 

c. Express version changes the detection slightly from the default detection script. 
It checks if the user has the product installed but does not have the request 
version of the product. If the version is not the right one it will tell the user to 
download the necessary version of the Flash player. 

5. Using Express Install events to your advantage 

http://www.adobe.com/products/flashplayer/download/detection_kit/�
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a. If the user says no to the Express install, modify the default code so the user has 
a choice what to do—perhaps another chance to upgrade and if not a chance to 
go to another page on your website. 

b. Open the playerProductInstallCallback.as file and write custom actions 
 
Making Flash Behave Like HTML 

1. Generating browser history using a hidden frame 
a. To see how this works go to http://robertpenner.com/index2.html and select the 

“back button” text. You can download the source files there as well.  
b. To accomplish this effect: 

i. Create a frameset, attach shell.html that contains the Flash application,  
ii. Create a history.html file and make sure that it contains an ID value 

 
1. Updating the history from within Flash 

c. Reload the history.html in the ActionScript of the Flash application file and target 
the proper frame. 

2. Forcing compatibility across browsers 
d. Use the Flash/JavaScript Integration Kit to notify Flash that the query string for 

the html page that contains the Flash application has changed.  
3. Handling back/forward button updates 

e. Import the JavaScriptFlashGateway.js into the shell file 
f. Use the uid variable which will make Flash communicate with the JavaScript 
g. Use the history.html file to update the current page’s ID and send this 

information to Flash. 
h. Inside the Flash file we will create an object that completes the communication 

between the html page, Flash, and the JavaScript. 
4. Why creating unique URLs is important 

i. In Flash, you can either have unique URLs or a working back button, but not 
both. 

j. Kevin Lynch’s archives show you how to do this. 
5. Using Shared Objects to manage states (in a form) 

k. Create a listener to check to see if the send button was pressed or not and then 
save the user’s data on the form 

l. Add an event listener to check each field’s information 

Extras- Animation Tricks in Flash 

1. Speed 
c. How fast should things go? Frame rates can be pushed up to 20-22 fps. Turn on 

onion-skinning to see a cascade of all your different frames together. 
2. Bounce 

d. Make sure you use gravity, easing in and out, stretch, squash, and sound effects. 
Make a path with a motion guide layer. Use the free transform tool to make a 

http://robertpenner.com/index2.html�
http://weblogs.macromedia.com/flashjavascript/�
http://klynch.com/apps/flashlinking/howto.html�
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one frame stretch and a one frame squash. Use the rotation tool to make the 
stretch and squash look realistic. 

3. Letters 
e. Use ease in and ease out again to create the bounce for the letters. Use the free 

transform to skew the letter of first retracting and then stretches as it slides and 
comes back to neutral as it arrives at its endpoint. 

4. Letter Cannon 
f. Inside the drum symbol, use shape tween to squash and bulge the cannon 

cylinder as it prepares to shoot and then create convex at the point of shooting. 
5. Squash Buttons 

g. Use preset button inside of a new symbol to apply skew (free transform tool) as 
it hits the “wall” and bounces off. Remember, when you squash in one direction 
you have to stretch it in the other. 

6. Ellipse Perspective 
h. Use shape tween and easing in and out to create a 3D effect on the disc where it 

appears that the object is turning in space 
7. Free Onion Draw 

i. You can move the onion-skin brackets to see the frames as the animate. Use the 
Modify> Convert to Blank Keyframes command to create a set of keyframes 
within which you can draw. 

8. Morph Symbol 
j. You can insert a series of blank keyframes inside of the tween after having 

created a motion tween. Turn on onion-skinning and then you can hand draw a 
set of distorted shapes that appear similar to the symbol itself. 

9. Drip 
k. Create a frame by frame animation and insert a bunch of regular frames in 

between each frame. Select the entire layer and convert the whole layer to a 
series of shape tweens. With onion-skinning turned on you can add and subtract 
additional frames as per needed.  

10. Lightning 
l. Add sound effect to timeline (set to Sync-stream). Create a separate layer of 

“flash” frames by changing the color of the stage with a solid white color for a 
single frame along multiple random frames along the timeline. The lightning itself 
has a combination of frames that have “follow-through” and frames that jump 
around. 

11. Interactive Lighting 
m. Use bitmap images created in an image editing program to create lighting 

effects. Oscillate between bitmap images within Flash. 
12. Anticipation and Follow Through 

n. Very similar to “Letters” (exercise 3). 
13. Traditional Layout Drawings 

o. Useful in comparing hand-drawn animations to Flash 
14. Nested Symbols 
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p. Allows you to “recycle” your animations. The animation consists of a set of 
symbols that have frame-by-frame animations drawn with onions-skinning turned 
on nested inside the symbol. These are then dropped on to the main timeline-- 
scaled, rotated, etc. Some of the symbols are nested three symbols deep. 

15. Swapping Symbols 
q. You can use the Property Inspector (not the Instance tab) to swap symbols. 

16. Rotoscope QuickTime 
r. Create a walk cycle by bringing in a QuickTime movie (put it on a guide layer), 

placing it on its own layer , creating a second layer, setting up a series of blank 
keyframes, and then “tracing” over the movie. 
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